1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Campag Freehub Issue...

Discussion in 'Bicycle Mechanics and Repairs' started by Stwutter, 1 Apr 2008.

  1. Stwutter

    Stwutter New Member

    I used to have Euros, and they were great wheels - the only trouble I ever had with them was that the freehub parls started sticking after about 6 months - eventually I bought a new freehub.

    Last year, I bought some bling bling gold Shamals. Again, great hoops, but after cleaning my bike today, I was spinning he wheels while running some lube over the chain, and the freewheel started making a grinding noise once every revolution, both backwards and whilst driving forward.
    I took the freehub off, and one of the parls was a bit 'sticky', and a little looser that the other two. I rubbed some excess grease off, and played around a bit, and it seems OK now.

    Has anyone had troubles with the Campag freehubs? I've always used Campag, but this seems to be a bit of a fault as it's unlikely to be coincidence. I've now just got my fingers crossed that it was just abit of grime or something...
     
  2. piedwagtail91

    piedwagtail91 Über Member

    4 members of one of the clubs i'm in have had campag freehubs fail this year, one of them twice. i'm not sure of the model, but shamal rings a bell.
    all had the same fault -pawl failure.
     
  3. GruB

    GruB New Member

    I have just replaced the pawl and all the bearings on my Scirroco. The bearings were not the sealed type, and with all the water I went through this year I'm not surprised they started to get a bit gritty. It was a very satisfying job to replace them all once I'd finished though.
    I am now quite knowledgeable about the insides of my Campag freehub.