1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Its on its way out :-(

Discussion in 'Bikes and Buying Advice - What Bike?' started by Iceniner, 5 Jun 2008.

  1. Iceniner

    Iceniner New Member

    Took my camera riding yesterday, got back home to review the footage - it was terrible, break-up of the picture, noise and even black outs :biggrin:

    Oh well its being returned to Archos a.s.a.p since its only a month old! Shame as its such a great product other wise. However in the first step the lady on the phone was very nice and helpful, lets hope the rest of the returns process is as smooth!
     
  2. magnatom

    magnatom Guest

    I would hazard a guess that it would be the lead into the back of the camera is faulty. It is easy to tug to hard on it. If mine gets tugged at all it does make the picture jump a bit, so I can imagine how it could be more permanently damaged. I hope i tis mended soon.....
     
  3. OP
    OP
    Iceniner

    Iceniner New Member

    Well they have already given me a returns number and everything else i need to do, so ill probably set about getting things in motion tomorrow. I did wiggle the cables around and im pretty sure its not the cable that goes into the camera.

    I think it might be the cable bit that goes into from the bottom of the camera lead to the travel base adaptor. It normally sits in my coat pocket, but i guess it must have been bashed around too much and has shaken it up. Where do you put yours when you ride?? Im thinking to put in inside my rucksak when i ride next and pray the cable doesnt get snagged on anything.
     
  4. magnatom

    magnatom Guest


    My Archos sits in the top pocket of my backpack. If it is raining I pull my rucksack raincover over and the cable is just long enough to acome around that and allow the mic to be attached to my rucksack strap (or if it is raining a lot I put itjust inside my waterproof jacket. The system isn't waterproof, but I've used it like this and not had any problems.

    Good luck getting it fixed!