Squeak from back wheel

zoso7

New Member
Location
Glasgow
I'm looking for some help, the past couple of times i've been out on my bike (2009 Giant Defy 2.5) i have noticed a squeak from the back wheel and not been able to track it down, now ive had it up in the stand i have gave it a going over and it turns out that the squeak is coming from a little rubber conical shaped thing that is on the non drive side between the out side of the hub and the inside face of the drop out, sometimes it spins fine with the wheel and there is no squeaking and sometimes it stops spinning and lets out an annoying squeak.

First of all, I hope you all know what part i am talking about, and secondly, how do i resolve this problem?!
 

Fab Foodie

hanging-on in quiet desperation ...
Hi
This is not an uncommon problem, my pal had it with his Giant SCR, exactly the same...
Unfortunately I can't remember exactly remember the fix though, certainly a bit of grease might help. IIRC, you can pull the rubber cone away enough to get some grease in there.
I'll try to remember to call him to refresh my memory.

If you bought it from a local shop, give 'em a call, I'm certain it's a common new-wheel problem that goes as it wears-in. It's bloody annoying though as I recall from riding with him!
 
OP
Z

zoso7

New Member
Location
Glasgow
Thanks for the replies guys, i will try a little bit of lube initially then if that doesn't work i'll take it into the shop i got it from!!

Fab Foodie, i would be interested to know how your friend resolved it if it varies to lubing or taking into the store.

Cheers
 
OP
Z

zoso7

New Member
Location
Glasgow
tried the drop of chain lube technique, worked a treat, went out for a 20miler today and not a peep, thanks guys!
 

fossyant

Ride It Like You Stole It!
Location
South Manchester
Grease........ TBH, I'd re-grease the hub, and refit...for the 'seal' to squeak, then there is likely to be a lack of grease in the hub.... just me being a fussy bugger........
 
Top Bottom