1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Computer Boffins - Help Needed

Discussion in 'CycleChat Cafe' started by stephec, 29 Nov 2007.

  1. stephec

    stephec Legendary Member

    Location:
    Bolton
    I have a problem with a usb memory stick. Until the other day it worked perfectly well, now all of a sudden it won't let me access anything on it.

    When I try to open it I get a box which says that it isn't formatted, if I try to format it I get a box which warns me I will lose any data on the stick.

    In properties the file system has somehow changed from fat to raw, does anyone know of a way to cure this? The manufacturer's and Microsoft's help website haven't be able to solve it so far. :biggrin::sad::biggrin:
     
  2. Van Nick

    Van Nick New Member

    Location:
    Leicester
    Hi stephec,

    I had a problem very similar to this with a Disgo USB memory stick. I think that the problem was caused because I shut my computer down before going through the "safe to remove hardware" procedure and next time I switched my computer back on, it must have "flashed" it. The data that I had on the memory stick was not the only copy, so I just went ahead and reformatted and then copied all my data back onto the memory stick.

    Tell us which USB stick and operating system you have, which may be useful.

    One thing to note is that I haven't had this problem again since I stopped using the software that came with the memory stick.

    Try using a different USB port.

    Also, have a look at the following page:-

    http://www.pcbuyerbeware.co.uk/USBProblems2.htm#recognised
     
  3. domtyler

    domtyler Über Member

    Not to put too fine a point on it, it sounds as if you have shagged the file system somehow. I trust you regularly back up your data and don't just keep all your most important files on a USB key? :biggrin:

    Just reformat and restore your files.
     
  4. stephec

    stephec Legendary Member

    Location:
    Bolton
    Errr.... :biggrin:

    I did have it set up so that it could be removed without having to use the safely eject hardware function, but I think I've knackered it. Thankfully there was nothing important on there.
     
  5. red_tom

    red_tom New Member

    Location:
    East London
    Done a bit of searching about. You could try Testdisk/Photorec. It's free and open source. Download the windows version from the link above and extract the zip file to a folder on your hard drive. Jam in the usb stick and then navigate to the testdisk-6.8.winwin directory and run photorec_win.exe. You'll then need to step through the menu, selecting the USB drive and where you want the recovered files to be saved to.
     
  6. stephec

    stephec Legendary Member

    Location:
    Bolton
    Red Tom, what a superstar, give that man a big cigar!!!!! :biggrin::biggrin::biggrin:

    I tried it and it's recovered about 95% of everything on the stick but it won't format now though so it must be totally goosed. Ah well you can't have everything, shoot happens. :biggrin:
     
  7. Abitrary

    Abitrary New Member

    I've found some memory sticks to be pretty crapily put together i.e. if you pull them out at the wrong angle, the connectors break.

    That's weird that the file system went before the hardware though and can happen if it's doing unusual amounts of read / writes, like running a temporary OS on it for example which'll burn it