CycleOps Magnus resistance issue

adetobee

Active Member
Location
Rotherham
Hi All,

I've just invested in a CycleOps Magnus and wondered if there are any Magnus owners here that can tell me if the following is normal for it?

When resistance is being applied to the Magnus by an app, say 10%, I tend to slow down after a minute or so since I'm no pro nor very young. When the speed drops below around 6mph, a speed I can happily grind away up a 10% slope all day at, the resistance suddenly disappears. Not a gradual reduction but like a switch being flipped. I'll then speed up, since there's no resistance, and once the speed gets above around 6 or 7mph the 10% resistance will suddenly kick back in. There's no loss in signal as this only happens when the speed drops below a certain point and since it happens on the two app I've tried so far, Rouvy and VeloReality, it does point to it being hardware related.

When I've raised this with the CycleOps support the response they've given is "The Magnus is only able to give a range of resistance based on the speed. When you are going at this slower speed, we are just not able to get this resistance out of the trainer to maintain it working correctly.". That's fine and I can sort of see the logic in it and if the resistance was reduced as you slowed down, say from 10% to 7%, that would make sense but it just doesn't seem right that it would suddenly cut the resistance when the speed drops below a certain point, e.g. 10% to 0%, and then reapply the resistance when the speed goes above a certain point, 0% to 10%.

Thanks in advance
 

gbb

Legendary Member
Location
Peterborough
This is just guesswork but I wondered how resistance trainers actually...physically work. Is it centrifugal force that throws weights or similar that exacts a greater resistance as speed increases ?...just theorising.
If it is centrifugal, then Cyclops response is probably spot on, at lower speeds, the centrifugal force is not great enough to create the resistance. Physics dictates when a certain speed is achieved, the force or speed is enough to start the process.

Just theorising. It's one of those things that doesn't matter to 99% of people...but it doesn't stop you wondering.
 

BikeCurious

Über Member
I have a CycleOps Magnus trainer too but do not experience what you have described. I use it with Strava and TrainerRoad and haven't had any problems. I will try VeloReality when I get the chance and see if I get the same problem. I assume you have tried all the usual advice of checking tyre pressure, roller tension and done a calibration through Rouvy? Are you connecting via Bluetooth or ANT+?
 
OP
A

adetobee

Active Member
Location
Rotherham
Hi both,

Thank you for your post and sorry for the delay in responding. I appreciate you both taking the time to respond.

gbb, the CycleOps Magnus uses electromagnets to control the resistance rather than mechanical resistance, which is why the various apps are then able to control the resistance remotely, or at least that's what I'm lead to believe.

BikeCurious, I have done all the usual things like tire pressure, roller tension (excellent clutch knob on the Magnus), and calibration. I'm connecting via ANT+ on the PC and the Magnus works flawlessly using Rouvy and VeloReality until the speed drops below around 6mph.

I have since been in touch with the customer support at Ribble cycles, where I bought it, and they have been very helpful. They have been in contact with CycleOps who have told Ribble Cycles that it definitely should not be doing that, which contradicts what the CycleOps support representative has been telling me. They've suggested updating the firmware first and if that doesn't work to return it. And that's were the new saga begins...I've been trying to update the firmware via the android app (can't use the PC unless you have the BlueGiga dongle and don't know anyone well enough with an iPad/iPhone that would trust me with it!) but there seems to be a bug with the app that causes it to loose connection with the Magnus as soon as you press the update firmware button. So I'm currently in contact with Rouvy support who have confirmed it is a bug.

So far my first experience with CycleOps isn't very positive at this point.
 
  • Like
Reactions: gbb
Top Bottom