Garmin 510 problems.

PlymSlimCyclist

Über Member
Location
Liverpool, UK
Hi folks,

I've had this problem happen twice now, and it's getting a little frustrating.
The Garmin was perfectly fine this morning. Recorded all my data appropriately and was turned off with over 65% battery.

I turned it on this evening to come home from work, and it's lost both bike profiles, all activity data, and when hitting Ride or Train, it refuses to go onto the appropriate screen to display your stats.

I'm about to master reset it, but wondering if anyone else has had this issue, and how they've overcome it.

Thank you :smile:
 

bpsmith

Veteran
Never experienced that. Sounds like a major issue though. A master reset is definitely the first port of call, once you have retrieved your data via your computer.
 

fossyant

Ride It Like You Stole It!
Location
South Manchester
I have a 705 and a 200. My first 200 started playing up after a few months. Similar stuff, shutting down at 60-70 percent charge.

I exchanged it, and my replacement has been fault free for 2 years of daily use, and a weekly charge. The 705 has been great.
 
OP
OP
PlymSlimCyclist

PlymSlimCyclist

Über Member
Location
Liverpool, UK
@bpsmith , Unfortunately, because it's cleared my original settings etc, I can't backup anything.

I've sync'd my activities, which fortunately it had recorded, but now it's the annoying aspect of re-setting it up, re-calibrating everything, and more annoying is the fact I don't know all the info offhand, so having to fetch it all (again).

@fossyant , I've had this since May, and the first time it cleared it all was a few months ago. Thought I had too many activities bogging it down, so cleared it all and went from there.
It gets charged when it's low, I sync as much as possible (by USB, as my phone is usually tied up with my headphones). I'm unsure if I should report it, or grit and bear it and see what happens.
 
OP
OP
PlymSlimCyclist

PlymSlimCyclist

Über Member
Location
Liverpool, UK
For now, I'll see how it behaves. Twice in a matter of months, considering I've owned it since May, isn't bad.
However, once it's all calibrated, I'm going to back up the settings, as fed up of setting it up. :smile:
 
Top Bottom