Memory-Map Overlays not sorting

Discussion in 'General Cycling Discussions' started by gom, 9 Mar 2019.

  1. gom

    gom Active Member

    Location:
    Gloucestershire
    Today I installed the latest Memory-May (v6.2.2) on my PC. First thing I noticed is that the list of "overlays" (tracks, routes and groupings of same) in the "Overlay Object" panel are in a seemingly random order. They used to be sorted alphanumerically, which I found just right.
    Anyone else found this?
    And anyone found a way to order them - manually or automatically? I hope I'm missing something obvious, but already spent far too long looking for a solution to a problem that should not exist.
    I emailed Memory-Map but no response yet (to be fair, it was only a couple of hour ago).
    :banghead:
     
  2. Supersuperleeds

    Supersuperleeds Guru

    Location:
    Leicester
    @ColinJ is an expert user, he may be able to help
     
  3. Bobby Mhor

    Bobby Mhor Wasn't born to follow

    Location:
    Home
    Just checked and mine are all over the place too...
    but I'm now updated to v6.2.2, ta!

    Support are usually on the ball..
    I'm sure my last query was answered by someone down In Australia....
     
  4. ColinJ

    ColinJ It's a puzzle ...

    My overlay lists have always been sorted in alphabetical order and still are!

    I can't find any way to change the order, but there must be a way if you two are seeing the overlays listed otherwise ... I'll keep on looking.

    Meanwhile ... If you haven't suffered from MM's slow loading and blank squares bug yet, you almost certainly WILL after a week or two of use. You should find this thread very useful! :okay:
     
  5. ColinJ

    ColinJ It's a puzzle ...

    Ah - I forgot that @gom has already been in that thread!

    I am also on v6.2.2 now and the fix is still needed.
     
  6. ColinJ

    ColinJ It's a puzzle ...

    I'm still poking around trying to get my lists NOT to be in alphabetical order.

    Meanwhile, in case you haven't picked up these 2 helpful MM tips ...

    1. If you are going to convert a track to a route, go into the properties of the track and set the 'Minimum update distance' to something small, e.g. 5 metres. That way, the route that is created will closely follow the track.
    2. If you want to join 2 tracks and the Minimum update distance is set too small, the tracks will not join unless you have the ends pretty much on top of each other. The fix for that is to set the update distance to something high, e.g. 500 metres.
    As you can see, those 2 requirements contradict each other, but you will soon notice if you have the setting wrong and now know what to do about it!
     
  7. ColinJ

    ColinJ It's a puzzle ...

    I managed to get the track list out of order by renaming tracks, but when I closed MM and reopened it, the list got resorted into alphabetical order.

    In fact, when I create a new track it is given the name 'Track' automatically and is inserted in the appropriate position in the list. If you rename it, it stays where it was in the list. If you did that several times, the list would look odd.

    Try closing MM and reopening it to see if the list gets sorted properly.
     
    Last edited: 9 Mar 2019
  8. OP
    OP
    gom

    gom Active Member

    Location:
    Gloucestershire
    Tried (1) closing MM & restarting (2) rebooting PC (3) exporting all overlays, deleting, re-importing. All to no effect.
    Created two new categories, z1 & z2. After close/open, z1 at the bottom, z2 about 1/3 of the way down. ???
    I also looked in the gpx file of the full export. At first I though things were following the order in the gpx (whatever may drive that), but that seems to break down once I'd looked a bit further.
    I have - touch wood - a backup of my system disk, which I can restore and so return to my previous version of MM where things sort. If I don't get a satisfactory response from MM by end of tomorrow, I shall try that.

    It would be nice if we could order things by dragging them around, but sorting is OK. At least I know where to find a given track or route. I prefix all my categories with a number+letter to get the order I want. With 1000+ tracks/routes they need to be in some sort of logical (to me) arrangement.

    I hope MM or I can get this fixed. For me this is a fatal flaw. When I was first looking at PC mapping, this folder-like list of tracks/routes was what fixed me on MM. I've been thinking I might update my OS 1:50,000 maps, but shall now wait and see what MM do.
     
  9. ColinJ

    ColinJ It's a puzzle ...

    They never got round to fixing the bug that my bodge works around, so don't hold your breath!

    It is quite interesting that several people are seeing the same thing. I use MM a lot and I have never noticed it happen to me.

    Mind you - I don't keep a lot of tracks and routes loaded in MM. I keep the ones ridden recently or being worked on for upcoming rides. The rest are archived in a rides folder system where I have full control over sort order and can easily search for old routes.
     
  10. OP
    OP
    gom

    gom Active Member

    Location:
    Gloucestershire
    No reply from Memory-Map. May try again, but then again may not.
    Anyway, restored system and now have version 6.1.4, which sorts.
    May be time to look at other mapping options - if I need to buy new mapping, don't want to find I have to "upgrade" to a broken version of Memory-Map.
     
  11. robgul

    robgul Guru

    And another issue?

    Just updated Mem Map to ver 6.2.2 (the latest) and the printing seems to have gone mad - pages print with large areas of map missing and just white space.

    Trying the "repair" option fails - before I a) delete Mem Map (incl the Registry entries) and/or B0 try and get an answer from mem Map - has anyone else had the same issue.

    I'm trying to us the "operations/print track" option to print a multi-page map with my route. It's been working like a dream for years but all of a sudden has failed. I've run the "cleaner" that fixes the display issue with grey tiles etc.

    Rob
     
    Bobby Mhor likes this.
  12. ColinJ

    ColinJ It's a puzzle ...

    Sorry, I can't help you with that one - I did print a few maps out 13-14 years ago when I didn't entirely trust my Garmin, but they were almost impossible to read having been printed on a cheapo non-colour laser printer. I haven't printed any since.

    These days I use my smartphone for backup. I have copies of all the UK OS maps on that.
     
  13. Bobby Mhor

    Bobby Mhor Wasn't born to follow

    Location:
    Home
    I upped to v6.2.2,
    tried a test map print, okay..
    possible problem between MM and printer?

    I tend to use the Windows Snip tool now for anything I want to print off MM, I just find it less hassle
     
  14. OP
    OP
    gom

    gom Active Member

    Location:
    Gloucestershire
    I’ve had this issue, even with 6.1.4 installed.

    I think it’s because not all the tiles have downloaded for the area being printed. As far as I can work out, MM downloads different tiles for different resolutions, even if the actual scale is unchanged. So if you are using e.g. 1:50K zoomed out and then zoom in, you can see MM downloading new tiles even for areas you saw before. For printing it now doubt uses the highest resolution.
    My fix is to zoom right in, and pan around to ensure all tiles are downloaded. Seems to have always worked for me.

    Does this make sense?
     
  15. YukonBoy

    YukonBoy Extra solar

    Location:
    Ultima Thule
    It does, that is how raster maps work.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice