Rear disk brake not working

pclay

Über Member
Location
Rugby
Hi

So I came off my cross bike a a few days ago on a patch of black ice. I wasn't injured, just more gutted that I have scraped my left shifter on my 4 week old bike.

The left shifter took the most damage, scraped the plastic down the side. Since my 'off', the rear disk brake has not really been working, and there are 2 distinct issues:

1, The brake lever on the shifter is sticking, and has now become very stiff, almost to the extent that I cannot operate it from the hoods. I can only operate it from the drops were I have more leverage.
2, The rear brake is not effective at all. I have it adjusted properly, but when i do apply the brake not much happens, ie the wheel still rotates. the pads do grab a little bit, but the stopping distance using rear brake alone has increased by about 5 times.

Is this likely to be a shifter issue, or a rear brake issue or both?

When I came off, the rear disc brake took a hit, as well as the left shifter - although there appears no physical damage to either, only cosmetic scrapes..

Any thoughts appreciated
 
Last edited:

fossyant

Ride It Like You Stole It!
Location
South Manchester
Check the cables pull through smoothly.
 

Torslanda

Regular
Location
Manchester
Disconnect the cable and check the operation of the lever as it may be bent.
Check the outer cable for damage/kinks which will make the cable stick.
With the cable disconnected check the operation of the caliper by hand,
It's possible the lever on the caliper may be bent and catching the caliper body.
HTH
 
OP
pclay

pclay

Über Member
Location
Rugby
thanks for the replies.

When I loosened the cable from the rear brake, the brake lever on the shifter worked normally. Although I could not see any obvious kinks in the cable, I removed the cable and have ordered new a inner and new outer cable.

Without any cable attached, the brake lever works fine. I will report back if new cables solved the problem.
 
OP
pclay

pclay

Über Member
Location
Rugby
So I got my new outer cable from eBay, and since my new inner cables still have not arrived, I bit the bullet and went to halfords for a new inner cable.

Just fitted them onto my bike, and low and behold, the rear brake is now working again, with no sticky brake lever. So thank you CC'ers, I was all ready to get a new brake / sti lever. You saved me a fortune.

If in doubt, swop the cables first.
 
Top Bottom