SKS mudguard snappage

phil_hg_uk

I am not a member, I am a free man !!!!!!
Email them, I lost the end caps that cover the end of the metal rods that support the mudguards and they sent me a whole set free of charge and this was on a secondhand bike.
 

phil_hg_uk

I am not a member, I am a free man !!!!!!
I was very impressed they emailed me back and asked for a picture for identification then emailed me and said they were on the way, I asked about payment and they said it was all prt of the service so who am I to argue :biggrin:

They took a little time to arrive but then they did have to come from germany.
 

buddha

Veteran
I've had it happen. The rear mudguard made a straight break much in the same way as yours - though they are about 3 years old.
IIRC I fixed it en-route by overlapping slightly and fixing with a pointy wood screw and rubber band:biggrin: When I got home, replaced that with a flat head screw and nut, and a bit of plastic glue. Still going strong 9ish months later.
 
phil_hg_uk said:
I was very impressed they emailed me back and asked for a picture for identification then emailed me and said they were on the way, I asked about payment and they said it was all prt of the service so who am I to argue :biggrin:

They took a little time to arrive but then they did have to come from germany.
I know Germany is an hour ahead but they got back to me at 7:36 asking for photos, that was quick ;)
 
HLaB, it has happened to me before. I didn't bother replacing it as I was planning on removing them from the Kinesis anyway.

Oh and now that I think of it it also happened on my Ridgeback some time ago.
 
Ironically I was going to remove them but thought, I'd better not, I'd jinx the weather. Looks like I'll have to remove them anyway and looking out the window, its seems like the weather is already jinxed.
 

potsy

Rambler
Location
My Armchair
I have a set of the SKS Raceblades and lost the mudflaps within days of fitting them,after reading this thread e-mailed them last night and today received a reply offering me some replacements FOC,well done SKS:biggrin: you now have another happy customer.
 

008

New Member
Location
NW London
I've had the exact same thing happen to me... twice! The first one was about 9 months old... but I did drop the bike so thought the damage must've been self inflicted. Decided to buy a second pair, and they cracked in half as well (definitely no chance of me causing it this time round), only this time they lasted less than 6 months.

Hmmm... I feel an email to SKS coming on.
 

sleekitcollie

Well-Known Member
HLaB said:
Well that's the replacements came today, very efficient by SKS :-)

The dilemna now is to fit them or not; I'm kinda liking the Kinesis without them :biggrin:
mine broke as well but i did catch them with my toe , its where the metal rivits join the plastig gaurd , went to shop to see if they did replacement fitting but they say know , wonder if SKS will do them , could u pm me the contact details pls
thanx
 
Top Bottom