Tacx Turbo Problem

grellboy

Über Member
Was on my Tacx Turbo earlier (Flow) when after a five minute warm up I started to do my intervals the Turbo suddenly went super hard to the point where I literally couldn't turn a wheel anymore. I use a power Meter so I adjust the power output myself using the gears rather than use my 520 or the Tacx itself, so it should stay at the same resistance rather than crank up madly. Any ideas what's going on?
 

beepbeep

Well-Known Member
Location
Yorkshire
is that a smart trainer?
I had the same issue with my tacx vortex smart running Zwift on an old an old laptop..It just seems to lock up so hard that even standing n the pedals I couldn't turn the rear wheel.I tried several times to re-calibrate the trainer using the Tacx app but it seems that the Zwift software and the old laptop had buggered up the trainer.....Got a new MACBOOK and and new ANT dongle . Reset the Zwift and tacx apps and never had another problem.
 
OP
grellboy

grellboy

Über Member
It is smart or semi smart or something but it's only connected to my Edge 520 so not sure I can go do the resetting route. Tried the IT Crowd method (turning it off and on again!) but that didn't seem to work either.
 

si_c

Veteran
Location
Wirral
If by "spin by hand" you mean use my hand on pedals to spin it then no, it's almost impossible.
I meant as @beepbeep presumably meant, when the power is off, can you spin the polished alloy flywheel on the right side (looking from rear) if not then it could be something binding inside.
 
Top Bottom