Tyre popping off rim - oops!

Gary P

Über Member
I went for a ride this morning and stuffed about 85psi into my rear Michelin 700X28c on the tourer.

Got about 5 miles in and was aware of tyre rub. When I stopped the tyre was off the rim for about 2 inches on 1 side and the tube was poking through! I had to deflate it, reseat they tyre and pump it up to about 50psi with the hand pump.

I was a bit surprised as the tyres are rated to up to 87psi on the sidewall.

Perhaps I hadn't seated it properly when I fitted it or perhaps the tube wasn't located properly?

Whatever the reason, it's a first for me.
 

Globalti

Legendary Member
Try refitting the tyre with talc then running it along the ground half-inflated before pumping up.
 

upsidedown

Waiting for the great leap forward
Location
The middle bit
Gary P said:
I went for a ride this morning and stuffed about 85psi into my rear Michelin 700X28c on the tourer.

Got about 5 miles in and was aware of tyre rub. When I stopped the tyre was off the rim for about 2 inches on 1 side and the tube was poking through! I had to deflate it, reseat they tyre and pump it up to about 50psi with the hand pump.

I was a bit surprised as the tyres are rated to up to 87psi on the sidewall.

Perhaps I hadn't seated it properly when I fitted it or perhaps the tube wasn't located properly?

Whatever the reason, it's a first for me.

I've had that happen 3 or 4 times on my Conti Contacts. Has only happened when i've been a bit enthusiastic with the track pump. Doesn't half turn heads when your rear tube explodes.
 
Top Bottom