Chainring shifting problem

Debian

New Member
Location
West Midlands
Today my front mech decided that it wouldn't change into the granny ring, it's been fine up till today.

This evening I decided to adjust it but try as I might I cannot get the full range of shifting. I can get high and middle, or middle and low but not all three. And it's not even that good then = if I change into top I then need to drop two clicks to get the chain back onto the middle ring after which I can change back up into two and the chain then happily stays in two.

What do you reckon? Knackered deraileur? I think it must be but before I spen money I'd like your expert opinions.

Thanks in advance.
 
The dérailleur might just need a good cleaning or your cables might be snagging (will need cleaning or replacing) or a combination of both.
 
OP
OP
Debian

Debian

New Member
Location
West Midlands
Cable is OK and free. Recently replaced.

Deraileur seems to have full range of movement - it's almost as if the two sides of the deraileur cage are too far apart so that one side or other is always too far away from the chain :angry:
 
I had a similar problem once on a bike with trigger shifters solved it by cleaning the deraileur, cleaning the cables and by opening and cleaning the shifters but had to keep on top of the cleaning to stop it recurring. Subsequently I replaced the trigger shifters with sti's and have had no problems and I still have the same derailleur. I'm guessing IMC it was either the new cables or the shifters or both.

Edit: just remembered when I decided to do something about it; it was when I was 1/2 way up Dunning hill (21% max) and I got stuck in the middle 42T ring and really needed the 30T Granny :angry:
 
OP
OP
Debian

Debian

New Member
Location
West Midlands
HLaB said:
I had a similar problem once on a bike with trigger shifters solved it by cleaning the deraileur, cleaning the cables and by opening and cleaning the shifters but had to keep on top of the cleaning to stop it recurring. Subsequently I replaced the trigger shifters with sti's and have had no problems and I still have the same derailleur. I'm guessing IMC it was either the new cables or the shifters or both.

Edit: just remembered when I decided to do something about it; it was when I was 1/2 way up Dunning hill (21% max) and I got stuck in the middle 42T ring and really needed the 30T Granny :angry:

'twas a similar situation for me today! :smile:

I'll give it a clean and see how it goes.
 
Top Bottom